Update Discord Server URL

August 19, Wed
Affected Service: Website
  • Update
    We have scheduled an update for your website. We will update the discord server link on the footer and on menu

    19:42, Aug 18 UTC
  • Update Scheduled
    The update is now scheduled successfully in our timeline

    19:47, Aug 18 UTC
  • Update in progress
    We started the update process

    07:58, Aug 19 UTC
Back to current status