Valorant roster

December 04, Fri
Affected Service: Website
  • Update Scheduled
    A new team “Valorant team” is going to get created. Some changes will get done to team members

    18:38, Nov 26 UTC
  • Update in progress
    Update Started

    08:24, Nov 28 UTC
  • Update
    Lipton has been removed

    08:27, Nov 28 UTC
  • Update
    Fortnite roster page has been optimized for mobile users

    08:29, Nov 28 UTC
  • Update
    Valorant roster page has been created. It will remain hidden until we have the required data to set it up

    08:30, Nov 28 UTC
  • Update Scheduled
    The update has been scheduled for this Friday

    06:45, Dec 03 UTC
  • Update
    The update process has been started

    17:02, Dec 04 UTC
  • Update
    Bevers has been inserted

    17:10, Dec 04 UTC
  • Update
    Holas has been inserted

    17:36, Dec 04 UTC
  • Update Completed
    The update has been completed

    17:36, Dec 04 UTC
Back to current status