We have a program maintenance for 29/03/20

March 29, Sun
Affected Service: Website
  • Identified
    The maintenance will start at 11:20 and will finish at 13:00

    08:18, Mar 29 UTC
  • Resolved
    Maintenance completed

    09:14, Mar 29 UTC
Back to current status