Updating and fixing some bugs

August 18, Tue
Affected Service: Website
  • Identified
    We will update the roster page and we will fix some bugs on main code

    08:23, Jul 25 UTC
  • Resolved
    The bugs on mobile devices has been received

    19:39, Aug 18 UTC
Back to current status