Update social media links and manager

March 12, Fri
Affected Service: Website
  • Update
    We will change some links and update team members

    07:16, Mar 12 UTC
  • Update Completed
    The social media and managers page has been updated

    07:21, Mar 12 UTC
Back to current status