Policies are under construction

February 26, Wed
Affected Service: Website
  • Update
    We generate privacy policy, cookies policy and terms and conditions page

    09:36, Feb 09 UTC
  • Resolved
    Privacy Notice, Cookies Policy and Terms of Use police have generated and installed in your website.

    08:02, Feb 26 UTC
Back to current status