Anastasios Alafouzos | Page Designing Process

January 19, Sun
Affected Service: Website
  • Identified
    Bio element optimisation and language translation

    19:49, Jan 16 UTC
  • Resolved
    Content is optimazided and reviewed

    14:01, Jan 19 UTC
Back to current status