Fetchy needs to activate

January 25, Sat
Affected Service: Store
  • Identified
    This shipping automated system needs to activate

    16:56, Jan 10 UTC
  • Monitoring
    Fetch Account is created under store@nlgesports.org license

    19:57, Jan 16 UTC
  • Resolved
    Decided not to be used yet

    18:54, Jan 25 UTC
Back to current status