Update mangers and fortnite roster

March 03, Wed
Affected Service: Website
  • Update Scheduled
    Some changes will apply for old and new players of the team

    06:36, Mar 03 UTC
  • Update in progress
    Update started

    07:35, Mar 03 UTC
  • Update
    Slow and blurry removed from managers roster

    07:37, Mar 03 UTC
  • Update
    Mike has been removed from fortnite roster

    07:38, Mar 03 UTC
  • Update Completed
    The requested update has been completed

    07:39, Mar 03 UTC
Back to current status