Update discord link server

January 18, Mon
Affected Service: Website
  • Update Scheduled
    A new server link for discord is available

    13:34, Jan 18 UTC
  • Update
    The link has been updated on the internal aystem

    13:35, Jan 18 UTC
  • Update Completed
    The link is now accessible

    13:35, Jan 18 UTC
Back to current status