Roaster Page Update

January 23, Thu
Affected Service: Website
  • Identified
    Completely new set up and organisation of the Players. Executive page for 4 of them (look at the Clients>NLGesports>Pages_File)

    19:46, Jan 16 UTC
  • Resolved
    Roster page completed

    18:41, Jan 23 UTC
Back to current status