Update Scheduled

August 22, Sat
Affected Service: Website
  • Update Scheduled
    An update is scheduled. In this update we will change some things on roster page

    17:39, Aug 21 UTC
  • Update in progress
    We started the update progress

    05:44, Aug 22 UTC
  • Update Completed
    We finished with all the parameters

    09:37, Aug 22 UTC
Back to current status